Just somewhere to keep my notes while I'm playing.

Thursday, November 19, 2009

Solaris 10 CPU Usage

psrinfo shows how many CPUs you have:

bash-3.00# psrinfo
0       on-line   since 08/24/2009 13:40:13
1       on-line   since 08/24/2009 13:40:18
2       on-line   since 08/24/2009 13:40:18
3       on-line   since 08/24/2009 13:40:18
4       on-line   since 08/24/2009 13:40:18
5       on-line   since 08/24/2009 13:40:18
6       on-line   since 08/24/2009 13:40:18
7       on-line   since 08/24/2009 13:40:18
8       on-line   since 08/24/2009 13:40:18

adding the –v option gives you details about those CPUs

bash-3.00# psrinfo -v | head
Status of virtual processor 0 as of: 11/19/2009 03:50:06
  on-line since 08/24/2009 13:40:13.
  The sparcv9 processor operates at 1165 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 1 as of: 11/19/2009 03:50:06
  on-line since 08/24/2009 13:40:18.
  The sparcv9 processor operates at 1165 MHz,
        and has a sparcv9 floating point processor.
Status of virtual processor 2 as of: 11/19/2009 03:50:06
  on-line since 08/24/2009 13:40:18.
bash-3.00#

“prstat -s cpu -n 10” is a bit like top, but it tells you what cpu you are running against



bash-3.00# prstat -s cpu -n 10
PID USERNAME SIZE RSS STATE PRI NICE TIME CPU PROCESS/NLWP
3138 900233 895M 588M cpu16 1 0 141:24:49 1.7% mysqld/26
1005 root 19M 18M sleep 59 0 38:34:21 0.0% esd/1
944 daemon 3192K 2208K sleep 29 0 0:00:00 0.0% statd/1
542 root 1768K 256K sleep 29 0 0:00:00 0.0% efdaemon/1
8633 root 1712K 1168K sleep 1 0 0:00:16 0.0% utmpd/1
165 root 7568K 4920K sleep 29 0 0:00:00 0.0% devfsadm/8
940 root 2992K 2136K sleep 29 0 0:00:00 0.0% keyserv/3
147 root 7464K 4472K sleep 29 0 0:00:00 0.0% syseventd/15
9 root 11M 11M sleep 29 0 1:00:07 0.0% svc.configd/12
7 root 32M 31M sleep 29 0 0:04:45 0.0% svc.startd/13
Total: 129 processes, 541 lwps, load averages: 1.12, 1.14, 1.18
bash-3.00#






You can the use the mpstat command to see how each processor is doing:








bash-3.00# mpstat          
CPU minf mjf xcal intr ithr csw icsw migr smtx srw syscl usr sys wt idl
0 80 0 566 264 53 50 0 2 9 0 203 2 2 0 96
1 1 0 193 15 2 25 0 0 1 0 57 0 0 0 99
2 0 0 48 8 0 15 0 0 0 0 12 0 0 0 100
3 0 0 8 3 0 5 0 0 0 0 4 0 0 0 100
4 15 0 72 8 0 15 0 0 2 0 33 0 0 0 99
5 0 0 4 3 0 4 0 0 0 0 1 0 0 0 100
6 0 0 5 7 1 10 0 0 0 0 0 0 0 0 100
7 0 0 5 6 0 9 0 0 0 0 0 0 0 0 100
8 64 0 369 22 0 47 0 2 7 0 185 3 1 0 96
9 3 0 73 3 0 6 0 0 1 0 22 0 0 0 100



mpstat –p 10 10”  will refresh the screen every 10 seconds

No comments: